ホーム > mixiユーザー(id:11806401) > mixiユーザーの日記一覧 > 【Ubuntu14.04】apt-get updateでcranのGPGエラーとかハッシュサムが適合しませんとか

mixiユーザー(id:11806401)

2015年11月14日05:10

1608 view

【Ubuntu14.04】apt-get updateでcranのGPGエラーとかハッシュサムが適合しませんとか

 このところUbuntu(14.04LTS amd64)の様々なアップデートが頻繁にやってくる。
 本当にやたら頻繁です。
 いつもはアップデートマネージャーで自動ポップアップ表示するのに任せてアップデートしているけど、今日、byobu terminalから、

$ sudo apt-get update
してみた。すると、次のようなエラーが出た。

------エラー表示部ここから----------------
W: 署名照合中にエラーが発生しました。リポジトリは更新されず、過去のインデックスファイルが使われます。GPG エラー: http://cran.es.r-project.org trusty/ Release: 以下の署名が無効です: KEYEXPIRED 1445181253 KEYEXPIRED 1445181253 KEYEXPIRED 144518125353181

W: http://cran.es.r-project.org/bin/linux/ubuntu/trusty/Release の取得に失敗しました

W: http://jp.archive.ubuntu.com/ubuntu/dists/trusty-updates/main/binary-amd64/Packages の取得に失敗しました ハッシュサムが適合しません

W: http://jp.archive.ubuntu.com/ubuntu/dists/trusty-updates/universe/binary-amd64/Packages の取得に失敗しました ハッシュサムが適合しません

W: http://jp.archive.ubuntu.com/ubuntu/dists/trusty-updates/main/binary-i386/Packages の取得に失敗しました ハッシュサムが適合しません

W: http://jp.archive.ubuntu.com/ubuntu/dists/trusty-updates/universe/binary-i386/Packages の取得に失敗しました ハッシュサムが適合しません

W: いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、古いものが代わりに使われます。
------エラー表示部ここまで----------------

で、byobu terminalの下端には、アップデートが3つあることを示す表示

3!

と赤色でなされていた。

 そこで
検索:署名照合中にエラーが発生しました。リポジトリは更新されず、過去のインデックスファイルが使われます。GPG エラー
●Ubuntu日本語フォーラム
インデックス » インストールとアップデート » 12.04(amd64)がアップデート不能に
https://forums.ubuntulinux.jp/viewtopic.php?id=13884

------引用ここから----------------
2012-07-14 15:49:32

shunta
メンバ
登録日: 2007-08-12
投稿: 19

結局自力で解決出来ました。
やっぱり英語の情報でないと、イカンようですね。

http://askubuntu.com/questions/127326/h … untu-12-04

Answers

first enter the following command in the terminal

sudo rm /var/lib/apt/lists/* -vf

then update your system by entering the following command in the terminal

sudo apt-get update && sudo apt-get upgrade

after this there should be no errors and everything should work fine.
------引用ここまで----------------

 で、ぼじょ犬も
$ sudo rm /var/lib/apt/lists/* -vf
しようかなと思ったけど、まず、アップデートマネージャーを起動してみた。すると

   このコンピューターのソフトウェアは最新です。

とな。
 もう一回
$ sudo apt-get update
してみる。今度は、cranがらみの

------エラー引用ここから----------------
W: 署名照合中にエラーが発生しました。リポジトリは更新されず、過去のインデックスファイルが使われます。GPG エラー: http://cran.es.r-project.org trusty/ Release: 以下の署名が無効です: KEYEXPIRED 1445181253 KEYEXPIRED 1445181253 KEYEXPIRED 144518125353181

W: http://cran.es.r-project.org/bin/linux/ubuntu/trusty/Release の取得に失敗しました

------エラー引用ここまで----------------
だけになり、byobu terminal下端のアップデート数表示は2!
 アップデートマネージャーを起動すると、やっぱり

   このコンピューターのソフトウェアは最新です。

とな。
 もう一回
$ sudo apt-get update
してみる。今度も、cranがらみのエラーだけで、byobu terminalの下端のアップデート数表示は1!(←なんで1個ずつ減っていくんだ??)
 アップデートマネージャーを起動すると、今度は1件アップデート有りとの表示で、

Ubuntuベース
  Daemon handling the Unity handling sessions

とな。
 とりあえずこれをそのままOKしてインストールする。
 で、もう一回
$ sudo apt-get update
すると、やっぱりcranがらみのエラー表示。下端のアップデート数表示はなくなった。

 そう言えばこの仮想マシンにRをインストールする時ってどうしたっけかな。
$ sudo rm /var/lib/apt/lists/* -vf
する前に調べようと思う。
0 0

コメント

mixiユーザー

ログインしてコメントを投稿する